Issue
A computer doesn't start and/or doesn't appear to start, even after confirming it is plugged in to power.
Environment
This article applies to laptop or desktop computers: typically Macintosh, Dell, HP or Lenovo (or other Windows-based computers).
Cause
There could be a display problem, circuit board problem, power-supply problem or a multitude of other issues.
Resolution
Take the computer to The Repair Shop at The Computer Store located in the basement of McNutt Hall on campus so the Computer Repair technicians can diagnose and repair the computer. They are Apple, Dell, HP and Lenovo certified technicians who can do warranty repair. If the device is of a brand not listed, please contact them to confirm they can do warranty repair on your device.
The Repair Shop can be contacted by:
Telephone: 603-646-1232
Email: The.Computer.Store@dartmouth.edu