Troubleshoot GlobalProtect VPN for Mac

Summary

This article provides some troubleshooting tips for the GlobalProtect client installed on a Mac computer

Body

This article provides some troubleshooting tips for the GlobalProtect client installed on a Mac computer. Below is a list of a few known issues.

Issue: Connecting Loop

The GlobalProtect client is sitting in a Connecting... loop.

Cause

The signed Palo Alto system extension was blocked from loading. Or the GlobalProtect enforcer kernel extension may not be updated correctly.

Resolution

The best solution may be to uninstall GlobalProtect and start over with a fresh installation.

Step-by-Step

Go to vpn.dartmouth.edu and download a copy of the GlobalProtect installer for Mac 32/64 bit GlobalProtect agent

  1. Use the installer to remove the GlobalProtect application.
  2. From the ~Library folder -> Preferences (in your user profile)
    • To open the ~Library folder, from the Finder, hold down the Option key and then click the Go menu to select the Library folder.
    • Remove the following plist files from the Preferences folder if they exist,
      • com.panopto.mac.plist
      • com.paloaltonetworks.GlobalProtect.settings.plist
      • com.paloaltonetworks.GlobalProtect.client.plist
  3. In the Keychain Access utility (app), under the Login keychain search for GlobalProtect application password entries and remove those that are there. 
  4. Restart your computer.
  5. Then use the GlobalProtect installer to reinstall GlobalProtect
  6. After the install, be sure to verify that there is nothing awaiting approval in the security settings (see steps below). Sometimes an "Allow" box is awaiting you, but the computer may not let you know that this is the case.

For Mac OS Monterey

  1. Open System Preferences
  2. Security and Privacy
  3. Click the General Tab
  4. Click Allow under the Allow apps downloaded from section

For Mac OS Ventura and newer

  1. Open System Settings
  2. Go to Privacy and Security
  3. Scroll down to Security
  4. Click the Open Anyway button (This button is available for about an hour after you try to open the app)

Another option to completely uninstall GlobalProtect

Using the Terminal application

sudo /Applications/GlobalProtect.app/Contents/Resources/uninstall_gp.sh

 

Reference articles - 

Uninstall the GlobalProtect App for macOS

Remove the GlobalProtect Enforcer Kernel Extension
 

Issue: VPN.dartmouth.edu not resolving

When visiting vpn.dartmouth.edu user may receive the following message: vpn.dartmouth.edu’s server IP address could not be found.

Environment

This article applies to users visiting the vpn.dartmouth.edu website on a Mac.  

Cause

If your web browser cannot resolve the vpn.dartmouth.edu website, the issue may be due to your DNS server settings.

Known issues with the following DNS servers:

  • 1.1.1.1
  • 1.0.0.1

Resolution

To resolve this issue, you can add the following DNS servers:

  • 129.170.17.4 - Dartmouth DNS server
  • 8.8.8.8 - Google DNS server

To add this DNS server do the following:

  1. Open System Preferences
  2. Open Network
  3. Click Advanced
  4. Click the DNS tab
  5. Add the following IP to your DNS Server's list: 129.170.17.4
  6. Move the newly added IP to the top of the list
  7. Click OK
  8. Click Apply
See Related Articles to the right for more information.

Details

Details

Article ID: 73746
Created
Thu 3/14/19 10:01 AM
Modified
Thu 8/1/24 8:28 AM

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Global Protect by Palo Alto Networks is Dartmouth's newly supported VPN client. This tool has replaced the F5 VPN client, also known as the Big-IP Edge client, and is available across different devices and operating systems.