Issue
An issue was discovered where certain models of Dell Laptops (primarily model 7490) could encounter an issue where the TPM (Trusted Platform Module) is not recognized by the Windows Operating System. This can cause BitLocker security technology on the unit to prompt for a key that the user would need to obtain from the ITC Service Desk.
Environment
Dell Laptops running Windows 10. Primarily model 7490 (Some Precision 5510's have had this occur as well).
Cause
Windows 10 uses a technology called BitLocker to encrypt the internal storage on the unit. This is a security requirement that we enable on Dartmouth hardware. The BitLocker functionality relies on the existence of a working TPM chip to function. When this situation occurs, it triggers the unit to prompt the user for a 48 digit BitLocker key that we have stored. This key can obtained by contacting the ITC Service Desk.
Resolution
In most cases the Service Desk is able to restore functionality for the user through a series of steps that can get the system to see the TPM chip again. This allows the user to continue to login and work as they had before.
Follow up work is required to apply additional fixes via Firmware updates. This will ensure the issue does not recur at a later date.If you are interested in additional information on BitLocker and TPM Technology please see Microsoft's official documentation on the subject here.
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